Ongoing AWS Service degradation

Incident Report for System Surveyor

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 19:06 CDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 19:06 CDT

Monitoring

This is to track an AWS outage that is affecting multiple services and is contributing to application timeouts and degraded performance.
Posted Oct 20, 2025 - 12:32 CDT
This incident affected: Application Website, API, Reporting Systems and AWS (AWS ec2-us-east-1, AWS apigateway-us-east-1, AWS elasticache-us-east-1, AWS rds-us-east-1, AWS ecs-us-east-1, AWS secretsmanager-us-east-1, AWS lambda-us-east-1, AWS cloudwatch-us-east-1).